We are having an Instability in our quoting Engine
Incident Report for Freightos
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 07:51 UTC
Investigating
We are currently investigating this issue.
Posted Apr 28, 2021 - 07:24 UTC
This incident affected: Quoting (Spot Quote Search).