We are having an Instability in some of our services impacting all customers.
Incident Report for Freightos
Resolved
The problem with Google has been resolved!
Posted May 06, 2022 - 13:33 UTC
Identified
The issue is identified to be from google side, google is working on the issue.
We will keep you posted.
Posted May 06, 2022 - 12:21 UTC
Investigating
We are currently investigating this issue.
Posted May 06, 2022 - 11:47 UTC
This incident affected: Quoting (Spot Quote Search), Integrations (Single Sign On (SSO)), User/Business Management (Login, Signup), and Shipment Management (Shipment Booking).