Instability in Billing details and payments
Incident Report for Freightos
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 04:57 UTC
Monitoring
Enhancement fixes have been released and services are now more stable.
Posted Feb 14, 2024 - 18:40 UTC
Update
We are continuing to investigate this issue.
Posted Feb 14, 2024 - 17:27 UTC
Investigating
We are currently investigating it.
Posted Feb 14, 2024 - 17:26 UTC
This incident affected: Shipment Management (Shipment Booking, Billing Information).