Searching Quotes is not Stable
Incident Report for Freightos
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 10:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 29, 2020 - 09:44 UTC
This incident affected: Quoting (Spot Quote Search).