MP ship.freightos.com is experiencing some loading problems
Incident Report for Freightos
Resolved
This incident has been resolved.
Posted Aug 21, 2019 - 16:38 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 21, 2019 - 16:37 UTC
Identified
The issue is identified and we are supporting a hot fix soon.
Posted Aug 21, 2019 - 16:33 UTC
This incident affected: User/Business Management (Login, Signup) and Shipment Management (Shipment Booking, Billing Information, Shipment Tracking, Shipment Messenger).