Accelerate Sites PDF download is failing

Incident Report for Freightos

Resolved

The incident has been resolved.
Posted Oct 26, 2025 - 14:59 UTC

Investigating

We are investigating the issue.
Posted Oct 26, 2025 - 14:04 UTC
This incident affected: Quoting (PDF Creator).