Some features Outage
Incident Report for Freightos
Resolved
Google had some networking issues that affected our servers. Everything is back to normal now!
Posted Nov 16, 2021 - 18:17 UTC
Investigating
Some of the servers are identified as unreachable, checking the root cause.
Posted Nov 16, 2021 - 18:06 UTC
This incident affected: Data Management (FUF Import, Data Workflow) and Shipment Management (Shipment Booking, Billing Information, Shipment Messenger).