Global Networking issue- latency while opening Freightos sites
Incident Report for Freightos
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 19:12 UTC
Investigating
We are currently investigating this issue.
Posted Jun 13, 2022 - 18:09 UTC